[Techtalk] nautilus thrashing my sata disks

Neko james.neko at gmail.com
Tue Feb 20 16:00:42 UTC 2007

Hi everyone! I've got a nice bizarre inscrutable problem for you.

I run Debian testing/unstable. I've added some lovely shiny SATA disks to my
system, mounted in removable enclosures.
If I use Nautilus to copy any files of around 10MB or above to the
partitions on these disks, the speed is abysmal and the disk audibly
thrashes around. I've got a 24MB file I've been shunting around my disks for
testing, and it takes about 15 seconds to copy to the SATA disks. Files over
100MB are right out.
On the other hand, using Nautilus to copy the same files to partitions on my
IDE drives is, of course, lightning fast.

At this point, you might be thinking, aha, the disks are being mounted with
some kind of nonbuffered IO flag like 'sync' - and I thought the same - but
they're not! Using standard tools like cp and rsync, I can copy files to the
SATA drives in milliseconds. I even tried using Nautilus to access the
drives via a loopback Samba connection, and things were fast with no

I've also tried using the Ubuntu Edgy livecd, and get the same result.

The only thing I can think of is that Nautilus or gnome-vfs have somehow got
it in their heads that these drives might be yanked out of the system at any
time, and aren't doing any buffered I/O. But the partitions are all mounted
at boot from my fstab, and /sys/block/sd{a,b}/removable are both 0. It's
Even my little usb mp3 player needs unmounting before it'll flush everything
to disk.

I'm out of ideas - I really need help on this one.

More information about the Techtalk mailing list