[Techtalk] OpenOffice and DocBook

Kathryn Andersen kat_lists at katspace.homelinux.org
Thu Apr 26 00:56:24 UTC 2007

OpenOffice hates me.
I am trying out using OpenOffice to write DocBook documents.
I've tried with both version 2.0 and 2.2.

What happens is that, I write an initial document, save it as DocBook,
and everything is fine, I have a DocBook document with sections and
titles and so on.  Where I've put a Heading 1 style, it saves as a sect1
section, and so on.

But when I open up the document in OpenOffice (rather than creating a
new document from scratch), it loses all my sections.  When I load
it, they no longer appear as sections, just paragraphs.  So I say, oh
well, and re-format the headers as headers.  I save the document; and
there are still no sections, just paragraphs.

I have tried this over and over again, with different versions, on
different boxes (one Linux CentOs, one Linux GenToo) and the same thing
happens all the time.

I've googled, but nobody else seems to have had this problem.

OpenOffice hates me.

Kathryn Andersen
 _--_|\     | Kathryn Andersen	<http://www.katspace.com>
/      \    | 
\_.--.*/    | GenFicCrit mailing list <http://www.katspace.com/gen_fic_crit/>
      v     | 
------------| Melbourne -> Victoria -> Australia -> Southern Hemisphere
Maranatha!  |	-> Earth -> Sol -> Milky Way Galaxy -> Universe

More information about the Techtalk mailing list