[Techtalk] Importing settings in Debian's OpenOffice 2

Akkana Peck akkana at shallowsky.com
Thu Feb 9 04:54:03 EST 2006

I tried OpenOffice 2.0.1 on Ubuntu "Dapper" yesterday and discovered
that it didn't import any of my OOo 1.x settings or templates that I
spent so long setting up. I really don't want to go through that
again: I want to find some way to import the existing settings.

I googled a bit, and it looks like there's a Debian bug:
where Debian's OOo package (which Ubuntu also uses) 
skips the initial "registration screen" step, which is
the step which would have offered to import older settings.

The bug has been open since October with no comments yet, so
I don't hold out much hope for it getting fixed any time soon.
But I haven't been able to find any workarounds.

There's a file called /usr/lib/openoffice2/program/configimport.bin
but when I run it on my .openoffice directory, it exits successfully
without importing any files or creating a new config dir. If I point
it instead at my .openoffice/1.1.0 directory, it dies with an error:

.. importing layer file:///home/akkana/.openoffice/1.1.0/LICENSEconfigimport.bin - Unhandled exception caught in main: "Configuration Parser: a com.sun.star.xml.sax.SAXParseException occurred while parsing: - {Parser Error: [ line 1]: syntaxerror }."

Dapper's java is from gcj, so that might be the problem there. I
have a Sun JDK elsewhere on my disk, so I could point /usr/bin/java
to that if it might help. Or I suppose I could remove the debianized
OOo2 and download one from openoffice.org; or go back to OOo1.
But there must be some way to get this package to work.

Has anyone found a way to get a Debian/Ubuntu OOo 2 to import settings?


More information about the Techtalk mailing list