[Techtalk] Sound problem

Robyn rmanning at sirion.net.au
Tue Oct 12 02:38:53 EST 2004

What I found with the snd-intel8x0 module is that I've got an OSS mixer
and ALSA mixer and if I turn up everything that's an output in both of
them I get sound. I haven't narrowed it down yet. I've got an AC'97
Audio Controller. I've seen this problem with 2 Socket A Via
motherboards and an Intel based laptop.

On Mon, 2004-10-11 at 06:17, David Sumbler wrote:
> I recently upgraded my Fedora Core 1 system to FC2.  It all went
> pretty smoothly, and I have managed to sort out most of the problems
> (such as the CDROM drive not working) myself.
> But I have a problem with the sound card, which worked fine before.
> When I boot the system, sound does not work.
> Having run system-config-soundcard, which tells me that the module
> snd-intel8x0 is being used, the sound is fine, and when I look at the
> output of lsmod, a whole lot of inter-dependent sound modules are
> listed.
> I then reboot - and the sound does not work, although all the relevant
> modules are still listed by lsmod.
> When I run system-config-soundcard again, the sound works; the output
> of lsmod is unchanged, though.
> So, how do I get the sound to work from boot?
> Incidentally, when I use 'play' at a command line, I get an error
> message, 'application sox uses obsolete OSS audio interface'.
> My /etc/modules.conf is
> alias eth0 8139too
> alias usb-controller usb-uhci
> alias sound-slot-0 i810_audio
> post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
> pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
> alias ieee1394-controller ohci1394
> alias char-major-195 nvidia
> # Note: for use under 2.6, changes must also be made to modprobe.conf!
> and my /etc/modprobe.conf is
> # Note: for use under 2.4, changes must also be made to modules.conf!
> alias eth0 8139too
> alias usb-controller uhci-hcd
> alias snd-card-0 snd-intel8x0
> alias ieee1394-controller ohci1394
> install sound-slot-0 /sbin/modprobe --first-time --ignore-install sound-slot-0 && { /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :; }
> remove sound-slot-0 { /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :; } ; /sbin/modprobe -r --first-time --ignore-remove sound-slot-0
> alias char-major-195* nvidia
> The lines relating to sound modules possibly date from when I was running FC1.
> FC1 uses a 2.4 kernel, and FC2 a 2.6 kernel.
> David

More information about the Techtalk mailing list