[Techtalk] mythtv issue

Christine Bussman olearyck at parpiped.geek-den.net
Sat Dec 18 09:34:22 EST 2004

Last week I set up a box to run MythTV, and it was working great.  
However, Wednesday night I made some changes so that I could connect 
with the frontend on another computer, and since then the backend has 
been really unstable.  It seems to crash every half hour or so, whether 
or not I'm running the frontend.  I've tried to put things back in the 
state they were before I made changes, but I don't know how to.  When 
the backend dies, it just disappears, but the init script still believes 
it is running.  I've checked the logs for both mythtv and mysql and can 
find nothing.  I tried running mythbackend at the console to look for 
interesting messages, but the only thing that looks at all wrong is the 
last line which simply tells me it died.

changes I made:
commented out the bind-address line in /etc/mysql/my.cnf
altered the permissions on mythconverg (the database used for mythtv) so 
that I could access it from other machines also

I can revert the first change, but I don't know how to fix what I did to 
the database.  I used several commands similar to grant all on 
mythconverg.* to <user>@<various things went here> identified by 
<password here>. 

Some information about my system:
vanilla 2.6.10 kernel
ivtv module (dual Hauppauge 250 cards)
lirc (Hauppauge remote)
Gentoo Linux

If someone could tell me how to put the database permissions back where 
they were (only for one user on localhost) or even suggest a way that I 
can restart mythbackend (a daemon in init.d) automatically if it has 
stopped, I would really apreciate it.

One other bit of information that might be of use: bios, dmesg, and 
/proc/cpuinfo all tell me that my processor is of type "unknown".  I've 
done some research and it seems a good possibility is that we got a 
mobile AthlonXP instead of the normal desktop model we thought we were 
buying.  I don't know why the thing would have worked for a few days and 
then started to have problems if this is the issue, but who knows when 
computer gremlins are involved :)


More information about the Techtalk mailing list