[Techtalk] problems with Xv extensions

perimorph perimorph at mindspring.com
Fri Aug 22 14:13:37 EST 2003

Okay, one more problem and then I'll shut up for a while if I'm not
helping anyone.  ^_-

Until a few days ago, everything worked.  I had mplayer working just
fine on a RedHat 9 system using the Xv (Xvideo) output.  Then, I
installed a number of programs in an effort to get VCD-compliant mpeg
encoding.  Somewhere along the way, Xv got broken.  Now, whenever I use
it, the video window is a garbled bunch of mostly-green wavy lines. 
They don't move, unless I'm moving a window on the desktop, in which
case I can see a little bit of movement in the Xv window, but it's still
just a big green mess.  Audio continues to play fine.

The programs I had installed, all compiled from source, were:


I have used the "make uninstall" scripts to remove all of these, with
the exception of ffmpeg which doesn't have an uninstall target in the
Makefile.  I uninstalled that one by manually deleting everything (as
far as I know) "make install" copied.

This didn't solve the problem, so I recompiled and installed mplayer. 
Same problem.  I compiled and installed xine to see if it could use Xv,
but that failed also.  I used the rpm program's verify option to make
sure all my XFree86 packages were correct, and they were.  I reinstalled
the main XFree86 package anyhow to make sure the Xv and Trident (video
card) drivers were okay.

I've also played around with the display's depth.  I have been using
24bpp, but 16bpp didn't help anything.  Same problems using a lower
resolution for the monitor.  I went through my XF86Config file and
couldn't find anything there that was wrong.  I've also used "xvinfo" to
make sure Xv thinks it's working properly and supporting YV12 and YUY2,
and I've looked at the XFree86 logs to make sure I'm not getting errors
related to video.

The "X11 XImage/Shm" driver (the one that does everything and then some
in software, which is very very slow) correctly displays video, so I
know the problem isn't with the (divx mpeg and etc) codecs.

I also made sure to restart the X server several times during all of

Which brings us to now..  I can't determine what program the problem is
in, I can't find anything useful with google, and I've tried everything
I can think of except for wiping off my root partition and reinstalling
RedHat 9.  Which I'd really prefer to avoid.  But I do need Xv, because
the other output drivers which work on my system take more CPU and RAM
than I have.  Xv was the only one that could keep things in sync.

If you have some other ideas I can try, _please_ tell me.  I'm
completely stuck.  Thanks.  :)  Sorry this post was so long, but I've
tried lots of stuff to fix it.

Ripping out her hair,

More information about the Techtalk mailing list