[Techtalk] Problems with up2date (RedHat 8)

Magni Onsoien magnio+lc-techtalk at pvv.ntnu.no
Fri Aug 1 11:41:16 EST 2003


When I got back to work after 4 weeks vacation the other day, I noticed
that one of the servers I manage wasn't updated and the status on RedHat
Network for it looked kind of odd, with no indication of RH-version.

When I looked at it today, I found that it was working perfectly well,
all services (that are supposed to run) running, but when I tried to
up2date it, I got the following error:

[root at corda root]# up2date -l
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 801, in ?
  File "/usr/sbin/up2date", line 573, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 737, in batchRun
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 55, in run
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 86, in
  File "/usr/share/rhn/up2date_client/packageList.py", line 85, in run
  File "/usr/share/rhn/up2date_client/packageList.py", line 109, in
    for p in obsoletePackages:
TypeError: iteration over non-sequence

rpm works perfect (not the "usual" problem in RH8, solved by deleting
/var/lib/rpm/_-db.00{1,2,3} and running "rpm --rebuilddb", which I also

Relevant versions:
[root at corda root]# rpm -q up2date
[root at corda root]# rpm -q python 
[root at corda root]# cat /etc/redhat-release 
Red Hat Linux release 8.0 (Psyche)
[root at corda root]# uname -srvpio
Linux 2.4.18-27.8.0 #1 Fri Mar 14 06:45:49 EST 2003 i686 i386 GNU/Linux

According to the eventlog (in RHN) an update was scheduled on June, 27,
but it's still pending. The last update via RHN before that was in May,
but I know 100% sure that I have installed appropriate updates between
May and June, 27, especially security updates (routinely done
immediately if relevant). Since the updates vai RHN are the only ones I
know for sure when was done, I don't have a log over my more manual
up2dates - so in short I have very few ideas about exactly when it
happened or what happened.

Detailed status for the last update:

"This action will be executed after 2003-06-27 14:56:39 (GMT).

This action's status is: Picked Up.
The client picked up this action on 2003-06-27 16:41:43 (GMT).
This action has not yet completed this action.

Errata Affected:

RHBA-2003:140-05 (Updated bash packages fix several bugs)"

I have several other RedHat 8-servers and none of them have the same
problem, all are updated to the newest update.

I have googled for the last line of error message from up2date, and get
a few hits on some errors in the redhat-config-package script, and even
if the real problem may be the same, I neither don't fully understand
the problem nor find the solution to mine.

Any solotion or hints towards one would be appreciated!

Magni :)
sash is very good for you.

More information about the Techtalk mailing list