[Techtalk] I lost my filesystem

Hanlie Pretorius hpretorius at pnp.co.za
Mon Apr 14 15:14:20 EST 2003


I'm fairly new to Linux and I use Redhat 8.

I had one disk that I shared between Windows 2000 and Linux. I then got a
new disk and loaded Linux on the second disk as well. I could see the old
Linux partition and Windows from the second disk and everything worked fine.

Then I used PartitionMagic in Windows to delete the old Linux partitions and
I extended the Windows partition to cover the whole disk. From that time on
the Linux boot sequence on the second disk stops where it tries to find my
root file system (the second partition on my 2nd hard disk - hdb2). It then
gives me the option to go to a shell and at that point I'm more or less in
the same place as a rescue boot.

Our systems administrators have looked at it and they say I've lost the
label of the partition or GRUB doesn't know where the parition is. Although
I can reload Linux on the second drive, I'd prefer to save everything that
I've setup on it from oblivion.

We've tried the following to solve the problem:

* change fstab to remove references to hda but the whole system is in
read-only mode and we can't save fstab (we can see the three partitions
* change the label of hdb2 with fdisk and parted

Can someone out there help me please? I feel very frustrated (and stupid!)


More information about the Techtalk mailing list