[Techtalk] Diagnosing a hardware problem

Maria Blackmore mariab at cats.meow.at
Fri Nov 15 18:08:30 EST 2002

On Fri, 15 Nov 2002, Vera Childs wrote:

> I tried each chip by itself. The memtest86 takes so long to actually get
> the errors, that I'll have to wait until I'm about to leave work before I
> start that on each one by themselves. But in the meantime, I tried booting
> my regular Mandrake installation disk. With both chips in their by
> themselves, it still hung at the same place.


> That's where it stops (in the middle of "revision"). So I tried playing
> with some options that I got from a google search. Adding "vga=normal" to
> the kernel options gets me a few lines farther:

Interesting, getting an idea


> Then it hangs. So then I tried adding "noprobe" and "apm=off". It booted
> this time! But then I got to the point where I was selecting the partition
> to install from, and it hung. Rebooted a few times with these same options,
> and sometimes it will hang at the normal place (the screen output just
> above this paragraph), and once it booted again and let me get past
> choosing the partition, but as I started to type the directory name to
> install from, it spontaneously rebooted!

It sounds like a reproducable problem, but when you use different options,
different amounts of memory are used, so different things end up in the
bit of sickly memory

> I think my computer is possessed. :)

or possibly just dusty/dirty

> Later today, I'll steal, I mean... borrow <g>, my officemate's memory and
> see if I get the same results with that. I'm starting to suspect
> something's up with the motherboard, although I'm not real good at
> diagnosing hardware problems like that.

I would suspect a motherboard problem, specifically it sounds like there
could be a pair of shorted address lines to the sockets, or possibly
cracked address lines, or a wonkly contact in the socket.  This is because
the same problem happens in the same place with both sticks.  Hmm, an
interesting thing to try is to try both sticks in all the sockets on the
board, by themselves, perhaps?

good luck


More information about the Techtalk mailing list