[Techtalk] "I need to use Windows because ..."

caitlynmaire at earthlink.net caitlynmaire at earthlink.net
Sun Aug 11 13:10:58 EST 2002

Hi, Suzi,

> I tried 
> to download an RPM and chickened out when it asked for a half a dozen 
> new dependencies.

Don't chicken out and install the dependencies.  That's the easiest way
to deal with it.

>  I then tried compiling from source overnight, it 
> crashed. 

Likely because you are missing something it needs.  Just because you're
not using a package doesn't mean the dependencies aren't there.  They
are.  If you need library x, you need it whether you compile from
source, uncompress a gzipped tarball or binaries, or use a package.

Here's an example.  I posted on here about getting my Toshiba Libretto
20CTA (an ancient paperback book-sized 486 subnotebook) to run a modern,
if stripped down, copy of Red Hat.  Having succeeded (thanks in part to
Telsa Gwynne and Alan Cox) I started looking at lightweight apps.  I got
the lastest version of SIAG Office downloads, but it needed xawm and the
Mowitz widget libraries.  It *should* have worked with xaw3d but
couldn't find where Red Hat's RPM was.  I installed Mandrake RPMs of
xawm, Mowitz, and SIAG, and all worked fine.  

It gets better.  I wanted a lightweight browser and I feel Dillo still
needs some work.  I wanted to try Kylie.  Ran the configure script just
fine but the makefile crashed because it couldn't find where the
Mandrake RPM had stuffed the Mowitz libraries.  I edited the makefile to
get it to compile.

The point:  you need all the bits that a program demands for it to work,
and the bits have to be where the program expects to find them.  There
is no getting around that.

> I tried downloading RH 8.0 and installing it on another 
> machine, OO wouldn't open.

Beta code.  Stick with the latest *stable* release.

> My latest OO bongle - I downloaded the tar 
> for 1.0.1 from the OO site.  I did the multiuser install bit as root,
> no problems.  When I went to do the user install, it said it was
> unable to creat folders.  (yes, I've bug reported) *sigh*

Did you check permissions in the directory where it tried to create the
folders?  That's the usual cause of that error.  I ran into it with one
of the earlier Star Office versions.
>  What I really really really want is for Corell's linux 
> versions to actually work, WP 10 is what I used over on Windows, and
> it is 10X the office suite of anything MS puts out.  WP9 blows. 
> *sigh* I'd prefer an office suite to a plain word processor because I
> need some sort of slideshow/presentation maker program.

Corel dropped WordPerfect for Linux after Microsoft gave them a bunch of
money.  Do not expect to see WP10 for Linux ever, and blame Microsoft. 
Open Office/Star Office is the only reasonable solution for you if you
need to import/export MS Office files well.  ApplixWare is the next best
> So I guess here the problem is, there are solutions but it is
> becomeing extremely painful to make them work.

Again, this is completely contrary to my experience with OpenOffice. 
> 2) Data analysis tools.  I needs an SPSS (Statistical Package for the 
> social sciences) clone for linux. 

Did you look at R (as was suggested on grrls-only by Kathy)?  Will it do
what you need?

> 4) still struggling with general laptop peripheral issues.  Linux
> laptop and USB support sucks.  Sorry, it just does. 

No, it sucks to *you*.  I've installed Linux on a number of *very* new
Toshiba and IBM laptops and got everything working relatively

> I am having trouble with 
> scanner support,

You keep saying this.  Which scanner?  What brand and model?  Is it one
that SANE does not support?

> camera support (had trouble getting Gphoto2 to install, 
> *sigh*),

On what distro?  It's part of a default RH 7.3 install.  The rpm goes
right in.  Again, you've repeated this on two lists but haven't supplied
an error message.

> reading flash cards (it simply doesn't recognise them)

Er... yes, it does, if you tell it the flash card is there.  It will not
autodetect it.  You have to create a mount point and add it to your
/etc/fstab file.  Then, when you install the flash card you have to
mount it.  It is treated just like another hard drive.

I stick the compact flash card from my digital camera in a compact flash
adapter all the time and use it in my Libretto 50CT, which has no USB
ports.  Here's the relevant line from my /etc/fstab file:

/dev/hdc1       /mnt/cf    vfat    user,noauto,fat=12      0 0

/mnt/cf isn't standard -- it's just the directory I chose.  I like all
removable media to be under /mnt (pretty much a UNIX standard) and /cf
is just my shorthand for "Compact Flash".  You could just as easily have
it mount to /flash or whatever is easiest for you.

vfat means an MS-DOS filesystem, which is what my camera writes.  It
happens that my camers writes FAT12 (not standard) as opposed to FAT16
or FAT32.  Fortunately, this was well documented online.  Hence the
fat=12 option.  The user option simply means I want any ordinary user to
be able to mount/unmount the card, and the noauto option means that I
don't want it automatically mounted at boot since it likely isn't there.

> CD 
> drive support for things like rescue CD's

Huh?  There.  Has been for a long time.  It was there in Red Hat 5.x. 
Red Hat 7.3 comes with a little sysadmin's rescue CD.  What specifically
are you looking to do?

> have yet to 
> play with the palm pilot software but I worry about that too...

Works right.  Has for about forever.

>  I can't 
> leave my USB CD drive plugged in for the constant stream of packets it
> sends back and forth with the OS, which slows the machine to a crawl,
> etc.

Huh?  Contrary to my experience, at least with a USB CD/RW.  What CD
drive (make and model), what kernel version, etc..?

You keep assuming things don't work that do.  Ask and ye shall receive,
or someother appropriate misquote.

All the best,

More information about the Techtalk mailing list