[Techtalk] connecting a dumb terminal

Katie Bechtold katie at katie-and-rob.org
Wed Aug 7 21:12:29 EST 2002

On Tue, Aug 06, 2002 at 10:02:30PM -0400, Jeff Dike wrote:
> 	Make sure the baud rates match.  The terminal should have some
> kind of setup where you can set its idea of the baud rate.  Make sure that
> matches whatever rate you're putting on the agetty command line.

I have managed to find the setup for the terminal.  Among the items
I can change (along with the values to which I currently have them
set) are:
- mode: ANSI or VT52 (VT52)
- x/on/xoff, rts/cts or off (rts/cts)
- Tx/Rx baudrate (9600)
- bits per char./parity/stops (8-none-1)

Accordingly, the applicable line in my /etc/inittab now reads:
t1:2345:respawn:/sbin/agetty -L -h 9600 ttyS1 vt52  

But still no luck.

> Another thing you might look at is a different getty.  This is a longer
> shot since the agetty man page says that it's suitable for fixed lines.
> So, if you're totally out of ideas, you might give mgetty a shot.

I tried mgetty instead, but that didn't seem to have any effect.

Now's the part where I admit that I was fooling around with it for a
few hours last night, trying all sorts of agetty options and
pressing all sorts of keys on the terminal's keyboard, and *once* I
somehow got it to work temporarily: I got my PC's login prompt on
its screen, I logged in, and everything seemed to be great.  But
then I logged out, and I couldn't reproduce whatever it was that got
me the login message and prompt. :(  I guess I'll just keep trying
to figure out what it was that I did right that one time.
Katie Bechtold

More information about the Techtalk mailing list