[Techtalk] kernel What have i done

Malcolm Tredinnick malcolm at commsecure.com.au
Wed Aug 7 15:35:50 EST 2002

On Wed, Aug 07, 2002 at 01:06:21AM -0400, Andrew wrote:
> 	HI All,
> I am triing to do a kernel up-grade fr source. I kept getting "file 
> not found" error every time make dep was given. It seemed not to 
> matter what I did by replacing the source, changing from 2.4.18 to 
> 2.4.19 nothing seemed to stop the "file not found" error.

_Which_ file is not found? Look at some of the last lines of make output
and tell us which file it is trying to build or find. There are usually
at least some clues there. I have seen this error before in kernel
builds, but I can't remember what the problem was -- maybe seeing the
place where it is blowing up will trigger my memory.

> SO I tried "make -i" then "make -i dep" both *seemed* to work. Should
> I go on or give up and find an RPM someplace. I must have tried 10
> times. prior to this "make -i" attempt.  -- 

Unless you have a very good reason for running 'make -i ...', it is
never the right solution. After all, it is just ignoring all your
errors, so "works" is a bit of a misnomer when applied to the results of
a 'make -i' run. :-)

Post some more information (like the context just before things blow up)
and we might be able to solve it here. Building a kernel from source is
very common and doesn't normally fail, so it's worth persisting with.


More information about the Techtalk mailing list