[Techtalk] Help, I'm confused

Almut Behrens almut_behrens at yahoo.com
Fri Oct 5 11:30:42 EST 2001

On Thu, Oct 04, 2001 at 05:56:44AM -0500, pmurphre at indiana.edu wrote:
> OK, I'm attempting to install Corel's WordPerfect for Linux.
> <snip>
> ... only to inevitably end up with a situation where the Runme
> script will activate and then be unable to locate any of the files
> necessary to perform the installation.  As I have untarred and
> unzipped the files and placed them in a directory (as instructed by
> the ever-so-helpful (heavy sarcasm) installation guide), I can't
> understand why the Runme script cannot seem to locate them.

(Note: I'm assuming that you're trying to install WordPerfect version 8.
Corel's more recent Office suite for Linux doesn't seem to be
downloadable anywhere, at least not from their website...)

As WP 8 dates back into 1998, my guess would be that you've run into
"the libc5/glibc issue" (BTW, glibc, libc6 and glibc2.* are normally
used synonymously -- compatibility-wise being a major departure from
the previously established libc5 library of basic system calls).
The problem can come in two flavors: either you don't have *some* of
the required old libc5 libraries, or you have no support for libc5 at
all. The latter situation usually produces rather incomprehensible
error messages, when you try to run older programs.

Normally, you can run "ldd" on any program (or shared library ".so"
file) to have it display which libraries it depends on, which libraries
it would be using (if it can find any), or, whether it can't find them.
For example, when running the command on the main WordPerfect binary
"xwp" (after a successful install) you would see something like

$ ldd xwp
    libXt.so.6 => /usr/i486-linux-libc5/lib/libXt.so.6 (0x4001c000)
    libX11.so.6 => /usr/i486-linux-libc5/lib/libX11.so.6 (0x4005e000)
    libXpm.so.4 => /usr/i486-linux-libc5/lib/libXpm.so.4 (0x400fe000)
    libc.so.5 => /usr/i486-linux-libc5/lib/libc.so.5 (0x40116000)

If it is missing some libraries, it prints "=> not found" for them.
On my SuSE-7.2 system at work, where I tried the install, I got
    libXpm.so.4 => not found
although I generally have the libc5 compatibility stuff installed
and all the other libs were found. This of course also kept the
graphical install wizard from starting... (though the text-mode
installation did work).  Other distros might exhibit other weird

Even worse, however, if the system not even finds the (old) dynamic
loader program "/lib/ld-linux.so.1" itself, you'll get the apparently
silly, windows-like error message

$ ldd xwp
/usr/bin/ldd: ./xwp: No such file or directory

or, if you try to start the program as usual, you'll get the not
exactly more informative message

$ ./xwp
./xwp: Command not found.

...solely made this way to confuse aspiring, innocent new linux users ;)
Without knowing what's going on behind the scenes, this seems to imply
that it is missing the "xwp" file (though it's there). However, what it
actually wants to tell you is, that it is missing "/lib/ld-linux.so.1".
The latter path/filename is hardcoded in the executable.  Be patient,
the puter sometimes is having slight difficulties expressing itself

Fortunately, there is another WordPerfect package from the "Peanut"
Linux distro which contains all the required files (in their proper
form, i.e. unpacked, as they should appear in the system after a
successful install), *including* all the prehistoric library files
which are needed by but not distributed with the original WordPerfect
package from Corel. So, you can (mis)use that peanut package to patch
up your system with the old libc5 stuff... Actually, I'd recommend
that you prefer this package to some more generic libc5 compatibility
packages which might exist for your distro. This way you can be sure
to have *exactly* what you need for WP.
(If no other program has been needing this kind of stuff so far, you
probably don't have to worry about messing up something by installing

Get the package from:


If the download is slow, you might want to try one of the mirror sites
listed here (the size is about 17MB):


When you've finished downloading it, run the following tar command
as root to extract/install the required libc5 library files.
(Don't try to install the whole package, though, as described in the
associated readme file at the peanut site -- this might screw up your
current system!)
As you probably know, running stuff as root is always a risky business,
so, before doing so, it might be a good idea to make sure that you're
not going to mess up something.  Check with the following commands
whether there would be clashes with possibly already existing files:

ls /lib/ld-linux.so.1
ls /usr/i486-linux-libc5/lib/

If you get "No such file or directory" in both cases, then you are
fine, meaning that the stuff about to be installed is *not* there
already, so nothing will get overwritten.
If you're of the paranoid kind, then you can additionally have listed
in full detail what will get installed, by running tar in 'list-only'
mode (option 't'), which by itself cannot do any harm:

tar tjvf WordPerfect8.tar.bz2  lib/  usr/i486-linux-libc5/lib/

Once you're sufficiently confident, run the real install command:

tar xjf WordPerfect8.tar.bz2 -C /  lib/  usr/i486-linux-libc5/lib/

Side note:
depending on which version of tar you have (use "tar --version" to find
out), you may need to use the option "I" instead of "j" -- i.e. pre-
1.13.18 versions need "I", 1.13.18 understands both "I" and "j", and
1.13.19 wants "j" and complains about "I" being obsolete...
Things would be boring, if we didn't have these tiny gotchas ;)

Now you should have all the libc5 stuff required by WP.

Finally, to make the new (=old) libs be found by the dynamic loader,
you need to add the path /usr/i486-linux-libc5/lib/ to the config
file /etc/ld.so.conf.  Just use your favorite editor to add a line
"/usr/i486-linux-libc5/lib" at the end of the file (or, if that
doesn't have the desired effect for some reason, try with explicit
libc-type specification, like this: "/usr/i486-linux-libc5/lib=libc5",
no spaces around the "="). Then run "ldconfig" (no options needed) to
have internal things be reread/updated... -- all as root, of course.

Last but not least, run the actual installation script "./Runme", as
you tried before. It *should* work now ;) -- and don't worry too much
about the 'helpful' hints in the Readme file. In the typical case,
circumstances should be just as required (i.e. $DISPLAY variable set
up correctly, etc. -- see Mary's reply for details)

Also note that the destination directory that you need to specify
during the installation, does have to exist already. Basically, you
could install into a typical system location like /usr/local/wp8, or
somewhere into your home directory. In the latter case you don't need
to be root to run the actual install.  I myself, for example, tried
/home/almut/test/wp8, which seems to have worked flawlessly. The
executable to startup WP would then be /home/almut/test/wp8/wpbin/xwp,
(or rather something like /home/murph/wp8/wpbin/xwp in your case) which
you might want to integrate into your desktop somehow -- it appeared to
me that the install 'wizard' can only create an icon for the CDE
desktop, which you probably won't be running on a linux box...

Hopefully, I've not completely scared you off from Linux by now...
Well, try to see it like this: for Windows problems you probably
wouldn't find as many people trying to be helpful as you can find
here :)  But admittedly, things can be tricky at times...

If my guess was way off, or if you need further help, just let us know.

> I don't think I am a stupid person, but I am starting to have grave
> doubts about my decision to switch to Linux, since I can't even manage
> to install a simple program.

Be assured that the problem is not you :)

Also, I share your view of the 'ever so helpful' readme file -- but
always keep in mind that IT technology is developing fast and two or
three years can bring with them quite a few incompatibilities. At the
time the document was written, it was normal to only have the libc5,
so why talk about potential future incompatibility issues?  Originally,
the installation most likely worked out-of-the-box ;)


- Almut

PS: WordPerfect 8 seems to have a comparatively small memory footprint
upon startup, btw -- just something around 6 MB.

More information about the Techtalk mailing list