[techtalk] New Linux Kernel

Marisa Mack marisa at teleport.com
Fri Mar 16 12:54:40 EST 2001

hmmm, you also might want to make sure that your previous
kernel src wasn't already sitting in /usr/src/linux. i like
to just make /usr/src/linux a link to the current kernel in
/usr/src, so it looks like this:

[marisa at carcinogen marisa]$ ls -l /usr/src
total 32
lrwxrwxrwx    1 root     root           12 Jan 29 21:55 linux -> linux-2.2.16
drwxr-xr-x    5 root     root         4096 Jan 29 21:55 linux-2.2.12
drwxr-xr-x   18 root     root         4096 Jan 29 21:54 linux-2.2.16
drwxr-xr-x   14 1046     xfs          4096 Mar 24  2000 v2.3.99-pre1
drwxr-xr-x   15 1046     xfs          4096 Mar 24  2000 v2.3.99-pre3
drwxr-xr-x   15 root     root         4096 Apr 26  2000 v2.3.99-pre5
drwxr-xr-x   14 1046     xfs          4096 Nov 18 01:27 v2.4.0-t4

although, looking now, there's really no reason to have stuff
as old as some of this laying around. heh.


On Fri, Mar 16, 2001 at 09:54:20AM -0800, puff_devil graced me with:
> I use Linux-Mandrake 7.0, which uses the 2.2.14-15
> kernel.  I have downloaded the new 2.4.2 kernel and
> decompressed it to my /usr/src/ directory, which made
> it "/usr/src/linux".  I went into this directory and
> typed in (as told in the readme file) "make config" or
> "make xconfig" (I tried this first, since I use
> xwindows).  The XConfig didn't work (putting it
> bluntly with all kinds of errors), and "make config"
> worked but when I did a "make dep" it came with all
> kinds of errors.  I am wondering if I am doing this is
> the right directory or something to that effect. 
> Thank You for your time...
> Richard Carnes


"On a normal ascii line, the only safe condition to detect is a 'BREAK'
 -everything else having been assigned functions by Gnu EMACS."

More information about the Techtalk mailing list