[techtalk] networking on laptop

fabienne hadkova fh at q-bus.com
Sat Jan 6 01:02:17 EST 2001

Hi, my name is Fabienne (from Switzerland so please excuse me if my english
is far from good), I have been following the list and learning from all the
posts for a long time.

I am fairly new to linux and sofar I didn't have any problem I couldn't
solve but I guess it had to start at some point, so this is my first
question to you;)

Somebody gave me a laptop (IBM Thinkpad) and I installed Red Hat 7 on it.
Everything works fine except for the network adapter.

the pcmcia-interface (is this the word?) seems to be ok.
the adapter is: Accton EN2216 PCMCIA Ethernet Adapter

eth0 didn't 'load' so I looked at the explanations on the redhat website:
and tried just about everything they suggest, to no avail.

My questions:

on the site, they mention the pcnet_cs module. This module is unavailable to
me when I try to choose a module for eth0, using the redhat kernel- or
network-interface. Is there a command that will show me which modules are
loaded into the kernel?

Since this module was unavailable, I just wrote it in the interface (I guess
this is propably stupid) with the result that (at least) eth0 tried to load
at startup, bringing up a big ugly red <FAILED> notice...

So I downloaded the drivers for win2k from my windows computer and searched
for the IO and IRQ in the *inf-file and used this information in the
kernel-interface (propably also stupid). It didn't help, as you propably

cardmgr 'finds' the card and even names it appropriatly.

Now I am totally at a loss as to what else I can try. I would be very glad
for any kind of advice. I must be misunderstanding something but I don't
even know what. Actually this special card is on the list of the cards that
should be recognized by Redhat 7, so maybe the problem is somewhere else,
but where?

Thanks in advance for any help


More information about the Techtalk mailing list