[techtalk] Really weird computer troubles

Lighthouse Keeper in the Desert Sun ccovingt at one-eyed-alien.net
Mon Jan 24 19:15:14 EST 2000

On Jan 24, Brian Engle conjectured:

> 1) ping the eth0(internal LAN) address of the linux box from the linux box
> (this meant the net card is working)

Did that, several times.  Worked.

> 2) ping your external IP(ppp0) address from the linux box (this means tcp/ip
> is set up right on the linux box)

That works, too (when I type the ip number correctly :P )

> 3) ping something outside your network (I like to use my ISP's name server)
> from the linux box (this means everything is right with the ppp connection)

That works.

> 4) ping a hostname, ie. myisp.net, from the linux box (this means your

That works fine.

> 5) ping the eth0(internal LAN) address of the mac from the mac (this means
> the netcard in the mac works)


> 6) ping the eth0(internal LAN) address of the linux box from the mac (this

No chance.  This is where the trouble starts.  The machines aren't
talking.  Pinging from Mac to linux makes the RX light from the mac's eth
card blink, but not the linux one.

> 7) ping the mac's eth0(internal LAN) address from the linux box (while this

Still no go, but this time *both* RX lights blink.  What's amusing is that
I am using the *exact same firewall script* that I was a month ago before
I got hacked.  It worked then.  It *should* work now.
I skipped these.

> 8) ping the linux boxes external (ppp0) IP address from the mac (this means
> the forwarding and tcp/ip are set up correctly)
> 9) ping the IP address of your ISP's primary nameserver from the mac (the
> result of this is twofold, if you can't get through to the DNS, we all know
> what happens, but it also tests to make sure the linux box is forwarding the
> info right)
> 10) ping the hostname of of your ISP, ie. "ping myisp.net" from the mac
> (this means you've got the nameserver info set up right on the mac)

> one other thing of note, based on your second problem with the ppp
> connection, if you're running /etc/rc.d/rc.firewall from /etc/rc.d/rc.local
> and this is supposed to run after the modem connects, if it doesn't connect,
> the script will still run, it will just throw out errors when you try to set

To clear up confusion:  we have one phone line, and only dial when we want
to go online.  The ip forwarding/ipchains starts at boot, not at pppd


First we go to Three Mile Island, then Chernobyl.  It's the Nuclear
Catastrophe Tour!			    
			-Adam W



techtalk at linuxchix.org   http://www.linuxchix.org

More information about the Techtalk mailing list