[techtalk] 1st time adding a modem to linux.

Rik Hemsley rik at kde.org
Sun Feb 13 02:43:32 EST 2000

#if Tania M. Morell
> Hello everyone,
> I'm hoping someone can help w/ my modem problems.
> I have a creative labs modemblaster flash pci dl5630 and I've installed
> linux on the computer which is already running win98.  Win98 had the
> modem on com3 irq 9 (it's pnp). I thought linux didn't like irq9 for a
> modem so i switched it to com1 irq5.
> Still no luck.
> I've tried this:  setserial /dev/ttyS0 uart 16450 port 0x3f8 irq 5
> When in kde, i use kppp to initialize and I always get "sorry, modem is
> busy".
> Anyway, I'm been working on this nonstop without luck since last night
> and i'm all out of coffee!
> Any ideas?
> I'll be happy to get ANY help at all.

Um.. Why are you using 'uart 16450' ? IIRC that's for old, slow
serial ports and new machines should have 16550. I don't know
that much about hardware though :)

It's a pci modem, so it should get an irq given to it automagically
unless you play with your BIOS. This means you just have to find
it :)

There is, of course, the possibility it's a 'winmodem' but I don't
know which modems are and aren't. I have been told that most PCI
modems are winmodems but there are some out now that aren't --
which is quite possibly what yours is.

Anyway, what you should do is to look at your boot messages and
see what serial ports get defined.

What other serial devices do you have ?

The best plan is usually to disable your second serial port
via the BIOS. This way it's quite likely that your modem will
take that and be given irq 3 (I think.)

Re: Your later mail:
/dev/cua* are deprecated in Linux and should just be ignored.

Also, keep trying with minicom. You shouldn't need to use
setserial as your modem should be set up automatically. You
just have to find it :)


135. Displace the canon with attitude.

techtalk at linuxchix.org   http://www.linuxchix.org

More information about the Techtalk mailing list