[techtalk] sound card help

Telsa Gwynne hobbit at aloss.ukuu.org.uk
Mon Dec 20 11:36:08 EST 1999

Disclaimer: I know nothing about sound cards. My machine is a Cyrix
MediaGX which has 'on-board sound', whatever that means. When I
eventually got a proper soundcard for it, I broke sndconfig, too :)

Chris said (at various times :))
> The following error occured running the isapnp program:   Don't know what
> do with CONFIGURE CTL0044/269079066 (LD2 on or around Line 346
> /etc/isapnp.conf:346--fatal-error occured parsing config file - no action
> taken
> Telsa, the version is Red Hat 6.0.  I just went to a console, said setup and
> chose the sound card option.  It looked really easy, it even had my sound
> card listed.  I believe I got this error when the sound test came up.  Any
> help/ideas would be appreciated.

Well, when it's Red Hat, my first idea is usually to check RH's Bugzilla 
to see if someone else has reported it too.

Bugzilla is where people are encouraged to report problems with the
software. It's not tech support, really, but if there's a fix, they'll
tell you, and if they fix the relevant they'll tell you. (Bugzilla is
just the name of the bug reporting and tracking software, btw. It grew 
out of the Mozilla project and other groups, including RH, now use it to
track their own bugs too.)

Red Hat's Bugzilla database is at http://bugzilla.redhat.com/bugzilla
(well, it is at the moment: RH seem to move things a lot, but that
one stays reasonably consistent). To report bugs, you need to get
yourself a login and password (fill in the online form.) You don't
need to be a 'registered Red Hat user' who bought a CD and filled
in some form with that to use it. I mention this cos I think some
people think that :) You can use it whether you bought RH or downloaded
it off the net.

If you just want to search bugzilla, I don't think you need a 

Anyway, the search form is a bit hairy with Lynx but fine with Netscape.
I clicked on every possible bug resolution (notabug, duplicated, etc),
left everything else empty, and selected 'setup' and 'sndconfig' from
the software list. I got a list of about 60 reports mentioning one or
the other, from RH 5.x on up, so I'll summarise :)

There are at least three people with AWE 32 problems. One bug was
closed cos the person didn't get back to them, but it sounded similar.
Someone else invoked sndconfig three different ways (via installation,
via setup and via sndconfig) and only one of them worked :) And 
another doesn't have AWE 32 in the subject line: it's bug 1640, and
it turned into quite a saga which I'm afraid I daren't summarise as
I don't understand it. It starts off with "it doesn't work the first
time you run it", and then just continues on and on :)

Bug 4643 reports the same format of error message you got, though 
with slightly different numbers. The suggestion was to upgrade to
the latest isapnptools from Rawhide (this is a section on their
ftp site where they put the latest versions of packages and brave
people try 'em out). The person who sent the report didn't reply
on whether that helped. They were running RH 6.0, too.

You could always report this to bugzilla. When you do, you get
an odd-format message back which shows you what's been entered.
Any responses in email come back in a 'unified diff' format: this 
means that they print out any lines which are now different with + 
and - signs in them to show what changed, and if something has been
added, they'll put a few lines for context and then just show
the new stuff. I mention this because when I first saw this stuff
I just stared, frankly :) To see the whole thing you can always look 
on the website. You can respond either via email or via the web. If 
you do, it's perhaps worth getting the latest isapnptools, trying 
after upgrading that, and mentioned that you tried the fix from
bug 4643 and it didn't work.

Reporting bugs via bugzilla is like reporting things to the gnome
bug tracker (which came from Debian's bug-tracker, btw :)). It's
a bit off-putting at first, but you get the hang of it, and it
can be very useful to know how to at least search the database.

I encourage everyone to report everything because then I don't 
feel so silly about reporting typos in man pages and comments in
config files :) It could be worse: I know someone who reports 
misspellings in /usr/dict/words... 

Digression aside, I hope this helps.

Telsa (who does have reasons for reporting trivia, honest!)

techtalk at linuxchix.org   http://www.linuxchix.org

More information about the Techtalk mailing list